decadence

個人のメモ帳

Lionへの移行に伴うmacportsの更新

何かダメなせいでエラーが発生しています.

Apple's Xcode Developer Tools (version 4.1 or later for Lion, 3.2 or later for Snow Leopard, or 3.1 or later for Leopard)

どうやらSnowLeopardの時はXcodeが3.2で良かったのだが,LionになるとXcode4.1が必要になるらしい.

というわけで先にXcodeを更新します.



現在のXcodeを一度削除します.

$ sudo /Developer/Library/uninstall-devtools --mode=all

次にAppStoreを開き,Xcodeの最新版を入れましょう.
実際にはインストーラーが入るので,それを実行してXcodeをインストールします.
きちんと入ればまたgccなどのコマンドが使えるようになります.

再度macportsに戻りましょう.

$ sudo port -d selfupdate
$ port version
Version: 2.0.3
$ sudo port -u upgrade outdated

どうやら上手くいったようなので,ついでにupgradeも.
いやはやmacports便利です.

広告を非表示にする